CVE-2022-25648

NameCVE-2022-25648
DescriptionThe package git before 1.11.0 are vulnerable to Command Injection via git argument injection. When calling the fetch(remote = 'origin', opts = {}) function, the remote parameter is passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1009926

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-git (PTS)buster1.2.8-1vulnerable
bullseye1.7.0-1vulnerable
sid1.9.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-gitsource(unstable)(unfixed)1009926

Notes

[bullseye] - ruby-git <no-dsa> (Minor issue)
[buster] - ruby-git <no-dsa> (Minor issue)
https://github.com/ruby-git/ruby-git/pull/569
Fixed by: https://github.com/ruby-git/ruby-git/commit/291ca0946bec7164b90ad5c572ac147f512c7159 (v1.11.0)
https://security.snyk.io/vuln/SNYK-RUBY-GIT-2421270

Search for package or bug name: Reporting problems