CVE-2022-2601

NameCVE-2022-2601
DescriptionA buffer overflow was found in grub_font_construct_glyph(). A malicious crafted pf2 font can lead to an overflow when calculating the max_glyph_size value, allocating a smaller than needed buffer for the glyph, this further leads to a buffer overflow and a heap based out-of-bounds write. An attacker may use this vulnerability to circumvent the secure boot mechanism.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3190-1, DLA-3190-2, DSA-5280-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
grub2 (PTS)buster2.06-3~deb10u1vulnerable
buster (security)2.06-3~deb10u4fixed
bullseye (security), bullseye2.06-3~deb11u6fixed
bookworm, bookworm (security)2.06-13+deb12u1fixed
trixie2.12-2~deb13u1fixed
sid2.12-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
grub2sourcebuster2.06-3~deb10u3DLA-3190-2
grub2sourcebullseye2.06-3~deb11u4DSA-5280-1
grub2source(unstable)2.06-5

Notes

https://lists.gnu.org/archive/html/grub-devel/2022-11/msg00059.html

Search for package or bug name: Reporting problems