CVE-2022-26846

NameCVE-2022-26846
DescriptionSPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2949-1, DSA-5093-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)buster, buster (security)3.2.4-1+deb10u9fixed
bullseye (security), bullseye3.2.11-3+deb11u5fixed
bookworm, sid4.1.5+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcestretch3.1.4-4~deb9u5DLA-2949-1
spipsourcebuster3.2.4-1+deb10u7DSA-5093-1
spipsourcebullseye3.2.11-3+deb11u3DSA-5093-1
spipsource(unstable)4.0.5-1

Notes

https://git.spip.net/spip/medias/commit/3014b845da2dd8ad15ff04b50fd9dbba388a9ca2
https://blog.spip.net/Mise-a-jour-critique-de-securite-sorties-de-SPIP-4-0-5-et-SPIP-3-2-14.html

Search for package or bug name: Reporting problems