CVE-2022-27114

NameCVE-2022-27114
DescriptionThere is a vulnerability in htmldoc 1.9.16. In image_load_jpeg function image.cxx when it calls malloc,'img->width' and 'img->height' they are large enough to cause an integer overflow. So, the malloc function may return a heap blosmaller than the expected size, and it will cause a buffer overflow/Address boundary error in the jpeg_read_scanlines function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3004-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
htmldoc (PTS)stretch1.8.27-8vulnerable
stretch (security)1.8.27-8+deb9u3fixed
buster1.9.3-1+deb10u3vulnerable
buster (security)1.9.3-1+deb10u2vulnerable
bullseye1.9.11-4+deb11u2vulnerable
bookworm, sid1.9.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
htmldocsourcestretch1.8.27-8+deb9u3DLA-3004-1
htmldocsource(unstable)1.9.15-2

Notes

[bullseye] - htmldoc <no-dsa> (Minor issue)
[buster] - htmldoc <no-dsa> (Minor issue)
https://github.com/michaelrsweet/htmldoc/issues/471
https://github.com/michaelrsweet/htmldoc/commit/31f780487e5ddc426888638786cdc47631687275

Search for package or bug name: Reporting problems