CVE-2022-2735

NameCVE-2022-2735
DescriptionA vulnerability was found in the PCS project. This issue occurs due to incorrect permissions on a Unix socket used for internal communication between PCS daemons. A privilege escalation could happen by obtaining an authentication token for a hacluster user. With the "hacluster" token, this flaw allows an attacker to have complete control over the cluster managed by PCS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5226-1
Debian Bugs1018930

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcs (PTS)buster0.10.1-2fixed
buster (security)0.10.1-2+deb10u1fixed
bullseye0.10.8-1vulnerable
bullseye (security)0.10.8-1+deb11u1fixed
bookworm, sid0.11.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcssourcebuster(not affected)
pcssourcebullseye0.10.8-1+deb11u1DSA-5226-1
pcssource(unstable)0.11.3-21018930

Notes

[buster] - pcs <not-affected> (Vulnerable code not present, see #1018930)
https://www.openwall.com/lists/oss-security/2022/09/01/4
https://bugzilla.redhat.com/show_bug.cgi?id=2116815
https://github.com/ClusterLabs/pcs/commit/de068e2066e377d1cc77edf25aed0198e4c77f7b

Search for package or bug name: Reporting problems