CVE-2022-27457

NameCVE-2022-27457
DescriptionMariaDB Server v10.6.3 and below was discovered to contain an use-after-free in the component my_mb_wc_latin1 at /strings/ctype-latin1.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.3 (PTS)buster1:10.3.34-0+deb10u1fixed
buster (security)1:10.3.36-0+deb10u2fixed
mariadb-10.5 (PTS)bullseye1:10.5.15-0+deb11u1vulnerable
mariadb-10.6 (PTS)bookworm, sid1:10.6.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.1source(unstable)(not affected)
mariadb-10.3source(unstable)(not affected)
mariadb-10.5source(unstable)(unfixed)
mariadb-10.6source(unstable)1:10.6.8-1

Notes

- mariadb-10.3 <not-affected> (Only affects MariaDB 10.4 onwards)
- mariadb-10.1 <not-affected> (Only affects MariaDB 10.4 onwards)
https://jira.mariadb.org/browse/MDEV-28098

Search for package or bug name: Reporting problems