CVE-2022-27811

NameCVE-2022-27811
DescriptionGNOME OCRFeeder before 0.8.4 allows OS command injection via shell metacharacters in a PDF or image filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1008320

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ocrfeeder (PTS)buster0.8.1-4vulnerable
bookworm, bullseye, sid0.8.3-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ocrfeedersource(unstable)(unfixed)1008320

Notes

[bullseye] - ocrfeeder <no-dsa> (Minor issue)
[buster] - ocrfeeder <no-dsa> (Minor issue)
[stretch] - ocrfeeder <no-dsa> (Minor issue)
https://gitlab.gnome.org/GNOME/ocrfeeder/-/merge_requests/13
https://gitlab.gnome.org/GNOME/ocrfeeder/-/commit/9209bce8afaf6fde19cdac7f5eaea1b744c3e79e (0.8.5)
https://gitlab.gnome.org/GNOME/ocrfeeder/-/commit/afea0e722f1d14eaf14bf0e5ebb444d3271ff1ef (0.8.5)

Search for package or bug name: Reporting problems