CVE-2022-28044

NameCVE-2022-28044
DescriptionIrzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3005-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lrzip (PTS)stretch0.631-1vulnerable
stretch (security)0.631-1+deb9u3fixed
buster0.631+git180528-1vulnerable
bullseye0.641-1vulnerable
bookworm, sid0.651-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lrzipsourcestretch0.631-1+deb9u3DLA-3005-1
lrzipsource(unstable)0.650-1

Notes

https://github.com/ckolivas/lrzip/issues/216
Fixed by: https://github.com/ckolivas/lrzip/commit/5faf80cd53ecfd16b636d653483144cd12004f46 (v0.650)

Search for package or bug name: Reporting problems