CVE-2022-28201

NameCVE-2022-28201
DescriptionAn issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. Users with the editinterface permission can trigger infinite recursion, because a bare local interwiki is mishandled for the mainpage message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3117-1, DSA-5246-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2vulnerable
buster (security)1:1.31.16-1+deb10u4fixed
bullseye1:1.35.4-1+deb11u2vulnerable
bullseye (security)1:1.35.8-1~deb11u1fixed
bookworm1:1.35.8-1.1fixed
sid1:1.39.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcebuster1:1.31.16-1+deb10u3DLA-3117-1
mediawikisourcebullseye1:1.35.8-1~deb11u1DSA-5246-1
mediawikisource(unstable)1:1.35.6-1

Notes

[stretch] - mediawiki <postponed> (Fix along in next security release)
https://phabricator.wikimedia.org/T297571
https://lists.wikimedia.org/hyperkitty/list/wikitech-l@lists.wikimedia.org/thread/YJNXKPV5Z56NSUQ4G3SXPDUIZG5EQ7UR/

Search for package or bug name: Reporting problems