CVE-2022-28281

NameCVE-2022-28281
DescriptionIf a compromised content process sent an unexpected number of WebAuthN Extensions in a Register command to the parent process, an out of bounds write would have occurred leading to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 91.8, Firefox < 99, and Firefox ESR < 91.8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2971-1, DLA-2978-1, DSA-5113-1, DSA-5118-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid127.0-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)115.12.0esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.12.0esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.12.0esr-1~deb12u1fixed
trixie115.11.0esr-1fixed
sid115.12.0esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:115.11.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.11.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.11.0-1~deb12u1fixed
trixie1:115.11.0-1fixed
sid1:115.12.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)99.0-1
firefox-esrsourcestretch91.8.0esr-1~deb9u1DLA-2971-1
firefox-esrsourcebuster91.8.0esr-1~deb10u1DSA-5113-1
firefox-esrsourcebullseye91.8.0esr-1~deb11u1DSA-5113-1
firefox-esrsource(unstable)91.8.0esr-1
thunderbirdsourcestretch1:91.8.0-1~deb9u1DLA-2978-1
thunderbirdsourcebuster1:91.8.0-1~deb10u1DSA-5118-1
thunderbirdsourcebullseye1:91.8.0-1~deb11u1DSA-5118-1
thunderbirdsource(unstable)1:91.8.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2022-13/#CVE-2022-28281
https://www.mozilla.org/en-US/security/advisories/mfsa2022-14/#CVE-2022-28281
https://www.mozilla.org/en-US/security/advisories/mfsa2022-15/#CVE-2022-28281

Search for package or bug name: Reporting problems