CVE-2022-28959

NameCVE-2022-28959
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4798-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)buster, buster (security)3.2.4-1+deb10u9fixed
bullseye (security), bullseye3.2.11-3+deb11u5fixed
bookworm, sid4.1.5+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcebuster3.2.4-1+deb10u3DSA-4798-1
spipsource(unstable)3.2.8-1

Notes

https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-SPIP-3-2-8-et-SPIP-3-1-13.html
https://thinkloveshare.com/en/hacking/rce_on_spip_and_root_me/
https://www.root-me.org/fr/Informations/Faiblesses-decouvertes/
https://github.com/spip/SPIP/commit/0394b44774555ae8331b6e65e35065dfa0bb41e4 (v4.0.0)
https://github.com/spip/SPIP/commit/6c1650713fc948318852ace759aab8f1a84791cf

Search for package or bug name: Reporting problems