CVE-2022-28960

NameCVE-2022-28960
DescriptionA PHP injection vulnerability in Spip before v3.2.8 allows attackers to execute arbitrary PHP code via the _oups parameter at /ecrire.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4798-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)buster3.2.4-1+deb10u7fixed
buster (security)3.2.4-1+deb10u8fixed
bullseye3.2.11-3+deb11u3fixed
bullseye (security)3.2.11-3+deb11u4fixed
bookworm, sid4.1.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcebuster3.2.4-1+deb10u3DSA-4798-1
spipsource(unstable)3.2.8-1

Notes

https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-SPIP-3-2-8-et-SPIP-3-1-13.html?lang=fr
https://github.com/spip/SPIP/commit/0394b44774555ae8331b6e65e35065dfa0bb41e4
https://github.com/spip/SPIP/commit/6c1650713fc948318852ace759aab8f1a84791cf

Search for package or bug name: Reporting problems