CVE-2022-29217

NameCVE-2022-29217
DescriptionPyJWT is a Python implementation of RFC 7519. PyJWT supports multiple different JWT signing algorithms. With JWT, an attacker submitting the JWT token can choose the used signing algorithm. The PyJWT library requires that the application chooses what algorithms are supported. The application can specify `jwt.algorithms.get_default_algorithms()` to get support for all algorithms, or specify a single algorithm. The issue is not that big as `algorithms=jwt.algorithms.get_default_algorithms()` has to be used. Users should upgrade to v2.4.0 to receive a patch for this issue. As a workaround, always be explicit with the algorithms that are accepted and expected when decoding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1011747

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pyjwt (PTS)buster1.7.0-2fixed
bullseye1.7.1-2fixed
bookworm, sid2.4.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pyjwtsourcestretch(not affected)
pyjwtsourcebuster(not affected)
pyjwtsourcebullseye(not affected)
pyjwtsource(unstable)2.4.0-11011747

Notes

[bullseye] - pyjwt <not-affected> (Vulnerable code not present)
[buster] - pyjwt <not-affected> (Vulnerable code not present)
[stretch] - pyjwt <not-affected> (Vulnerable code not present)
https://github.com/jpadilla/pyjwt/security/advisories/GHSA-ffqj-6fqr-9h24
https://github.com/jpadilla/pyjwt/commit/9c528670c455b8d948aff95ed50e22940d1ad3fc (2.4.0)
https://github.com/jpadilla/pyjwt/releases/tag/2.4.0

Search for package or bug name: Reporting problems