CVE-2022-29500

NameCVE-2022-29500
DescriptionSchedMD Slurm 21.08.x through 20.11.x has Incorrect Access Control that leads to Information Disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs1010634

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)stretch16.05.9-1+deb9u4vulnerable
stretch (security)16.05.9-1+deb9u5vulnerable
buster, buster (security)18.08.5.2-1+deb10u2vulnerable
slurm-wlm (PTS)bullseye20.11.7+really20.11.4-2vulnerable
bookworm, sid21.08.8.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)(unfixed)
slurm-wlmsource(unstable)21.08.8.2-11010634

Notes

https://lists.schedmd.com/pipermail/slurm-announce/2022/000072.html
https://github.com/SchedMD/slurm/commit/500787548cf3da22cc69ca2111ce51f77543849b (slurm-21-08-8-1)
https://github.com/SchedMD/slurm/commit/5b78f713f4b2e390ce80ad754b1240ad36e355ee (slurm-20-11-9-1)

Search for package or bug name: Reporting problems