CVE-2022-29501

NameCVE-2022-29501
DescriptionSchedMD Slurm 21.08.x through 20.11.x has Incorrect Access Control that leads to Escalation of Privileges and code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5166-1
Debian Bugs1010633

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)buster, buster (security)18.08.5.2-1+deb10u2vulnerable
slurm-wlm (PTS)bullseye (security), bullseye20.11.7+really20.11.4-2+deb11u1fixed
bookworm, sid21.08.8.2-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)(unfixed)
slurm-wlmsourcebullseye20.11.7+really20.11.4-2+deb11u1DSA-5166-1
slurm-wlmsource(unstable)21.08.8.2-11010633

Notes

[buster] - slurm-llnl <no-dsa> (Too intrusive to backport)
https://lists.schedmd.com/pipermail/slurm-announce/2022/000072.html
https://github.com/SchedMD/slurm/commit/ef62acfd2a566afc5187c554e908e4aa975211a1 (slurm-21-08-8-1)
https://github.com/SchedMD/slurm/commit/863c763c241db46039c27c4b7438ef5d33defb12 (slurm-20-11-9-1)

Search for package or bug name: Reporting problems