CVE-2022-29631

NameCVE-2022-29631
DescriptionJodd HTTP v6.0.9 was discovered to contain multiple CLRF injection vulnerabilities via the components jodd.http.HttpRequest#set and `jodd.http.HttpRequest#send. These vulnerabilities allow attackers to execute Server-Side Request Forgery (SSRF) via a crafted TCP payload.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1013270

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jodd (PTS)buster3.8.6-1vulnerable
sid3.8.6-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
joddsource(unstable)(unfixed)1013270

Notes

[buster] - jodd <no-dsa> (Minor issue)
https://github.com/oblac/jodd-http/issues/9
Fixed by: https://github.com/oblac/jodd-http/commit/e50f573c8f6a39212ade68c6eb1256b2889fa8a6 (v6.2.1)

Search for package or bug name: Reporting problems