CVE-2022-3100

NameCVE-2022-3100
Descriptionaccess policy bypass via query string injection
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3136-1, DSA-5247-1
Debian Bugs1021139

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
barbican (PTS)buster1:7.0.0-1vulnerable
buster (security)1:7.0.0-1+deb10u1fixed
bullseye1:11.0.0-3vulnerable
bullseye (security)1:11.0.0-3+deb11u1fixed
bookworm, sid1:15.0.0-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
barbicansourcebuster1:7.0.0-1+deb10u1DLA-3136-1
barbicansourcebullseye1:11.0.0-3+deb11u1DSA-5247-1
barbicansource(unstable)1:15.0.0~rc3-11021139

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=2125404
https://review.opendev.org/c/openstack/barbican/+/859852

Search for package or bug name: Reporting problems