CVE-2022-31623

NameCVE-2022-31623
DescriptionMariaDB Server before 10.7 is vulnerable to Denial of Service. In extra/mariabackup/ds_compress.cc, when an error occurs (i.e., going to the err label) while executing the method create_worker_threads, the held lock thd->ctrl_mutex is not released correctly, which allows local users to trigger a denial of service due to the deadlock.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.3 (PTS)buster1:10.3.34-0+deb10u1fixed
buster (security)1:10.3.25-0+deb10u1vulnerable
mariadb-10.5 (PTS)bullseye1:10.5.15-0+deb11u1fixed
mariadb-10.6 (PTS)bookworm, sid1:10.6.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.1source(unstable)(unfixed)
mariadb-10.3sourcebuster1:10.3.34-0+deb10u1
mariadb-10.3source(unstable)(unfixed)
mariadb-10.5sourcebullseye1:10.5.15-0+deb11u1
mariadb-10.5source(unstable)(unfixed)
mariadb-10.6source(unstable)1:10.6.6-1

Notes

https://github.com/MariaDB/server/pull/1938
https://github.com/MariaDB/server/commit/7c30bc38a588b22b01f11130cfe99e7f36accf94 (mariadb-10.2.42)

Search for package or bug name: Reporting problems