CVE-2022-31737

NameCVE-2022-31737
DescriptionA malicious webpage could have caused an out-of-bounds write in WebGL, leading to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 91.10, Firefox < 101, and Firefox ESR < 91.10.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3040-1, DLA-3041-1, DSA-5156-1, DSA-5158-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid124.0.1-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)115.9.1esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.9.1esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.9.1esr-1~deb12u1fixed
trixie115.8.0esr-1fixed
sid115.9.1esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:115.9.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.9.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.9.0-1~deb12u1fixed
sid1:115.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)101.0-1
firefox-esrsourcestretch91.10.0esr-1~deb9u1DLA-3040-1
firefox-esrsourcebuster91.10.0esr-1~deb10u1DSA-5156-1
firefox-esrsourcebullseye91.10.0esr-1~deb11u1DSA-5156-1
firefox-esrsource(unstable)91.10.0esr-1
thunderbirdsourcestretch1:91.10.0-1~deb9u1DLA-3041-1
thunderbirdsourcebuster1:91.10.0-1~deb10u1DSA-5158-1
thunderbirdsourcebullseye1:91.10.0-1~deb11u1DSA-5158-1
thunderbirdsource(unstable)1:91.10.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2022-20/#CVE-2022-31737
https://www.mozilla.org/en-US/security/advisories/mfsa2022-21/#CVE-2022-31737
https://www.mozilla.org/en-US/security/advisories/mfsa2022-22/#CVE-2022-31737

Search for package or bug name: Reporting problems