CVE-2022-32292

NameCVE-2022-32292
DescriptionIn ConnMan through 1.41, remote attackers able to send HTTP requests to the gweb component are able to exploit a heap-based buffer overflow in received_data to execute code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3105-1, DSA-5231-1
Debian Bugs1016976

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
connman (PTS)buster1.36-2.1~deb10u2vulnerable
buster (security)1.36-2.1~deb10u3fixed
bullseye1.36-2.2vulnerable
bullseye (security)1.36-2.2+deb11u1fixed
bookworm, sid1.41-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
connmansourcebuster1.36-2.1~deb10u3DLA-3105-1
connmansourcebullseye1.36-2.2+deb11u1DSA-5231-1
connmansource(unstable)1.41-21016976

Notes

https://lore.kernel.org/connman/20220801080043.4861-5-wagi@monom.org/
https://bugzilla.suse.com/show_bug.cgi?id=1200189
https://git.kernel.org/pub/scm/network/connman/connman.git/commit/?id=d1a5ede5d255bde8ef707f8441b997563b9312bd

Search for package or bug name: Reporting problems