CVE-2022-32749

NameCVE-2022-32749
DescriptionImproper Check for Unusual or Exceptional Conditions vulnerability handling requests in Apache Traffic Server allows an attacker to crash the server under certain conditions. This issue affects Apache Traffic Server: from 8.0.0 through 9.1.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3385-1, DSA-5311-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trafficserver (PTS)buster8.0.2+ds-1+deb10u6vulnerable
buster (security)8.1.7-0+deb10u3fixed
bullseye8.1.9+ds-1~deb11u1fixed
bullseye (security)8.1.10+ds-1~deb11u1fixed
bookworm9.2.3+ds-1+deb12u1fixed
bookworm (security)9.2.4+ds-0+deb12u1fixed
sid9.2.4+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trafficserversourcebuster8.1.6+ds-1~deb10u1DLA-3385-1
trafficserversourcebullseye8.1.6+ds-1~deb11u1DSA-5311-1
trafficserversource(unstable)9.1.4+ds-1

Notes

https://lists.apache.org/thread/mrj2lg4s0hf027rk7gz8t7hbn9xpfg02
https://github.com/apache/trafficserver/pull/9243
https://github.com/apache/trafficserver/commit/71a80d1abb3fbcb2e30ff850c8bca0a371589b5a (master)
https://github.com/apache/trafficserver/commit/590f87304b233791169af3d5899c5ba135bb61fa (9.1.x)

Search for package or bug name: Reporting problems