DescriptionCommand injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1023625

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet-module-puppetlabs-apt (PTS)buster, bullseye6.1.1-1vulnerable
sid, trixie, bookworm9.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bullseye] - puppet-module-puppetlabs-apt <no-dsa> (Minor issue)
[buster] - puppet-module-puppetlabs-apt <postponed> (Minor issue, rare condition, follow buster status) (v9.0.0)

Search for package or bug name: Reporting problems