CVE-2022-3275

NameCVE-2022-3275
DescriptionCommand injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1023625

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet-module-puppetlabs-apt (PTS)bookworm, sid, buster, bullseye6.1.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppet-module-puppetlabs-aptsource(unstable)(unfixed)1023625

Notes

[bullseye] - puppet-module-puppetlabs-apt <no-dsa> (Minor issue)
[buster] - puppet-module-puppetlabs-apt <postponed> (Minor issue, rare condition, follow buster status)
https://puppet.com/security/cve/CVE-2022-3275
https://github.com/puppetlabs/puppetlabs-apt/commit/c26ad2a54f318b4d6fbe55f837b00cd6afd9f1eb (v9.0.0)

Search for package or bug name: Reporting problems