CVE-2022-33127

NameCVE-2022-33127
DescriptionThe function that calls the diff tool in Diffy 3.4.1 does not properly handle double quotes in a filename when run in a windows environment. This allows attackers to execute arbitrary commands via a crafted string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-diffy (PTS)stretch3.0.6-1fixed
buster3.2.1-1fixed
bookworm, sid, bullseye3.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-diffysource(unstable)(not affected)

Notes

- ruby-diffy <not-affected> (Windows-specific)

Search for package or bug name: Reporting problems