CVE-2022-34481

NameCVE-2022-34481
DescriptionIn the <code>nsTArray_Impl::ReplaceElementsAt()</code> function, an integer overflow could have occurred when the number of elements to replace was too large for the container. This vulnerability affects Firefox < 102, Firefox ESR < 91.11, Thunderbird < 102, and Thunderbird < 91.11.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3064-1, DSA-5172-1, DSA-5175-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid123.0-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)115.7.0esr-1~deb10u1fixed
bullseye (security), bullseye115.7.0esr-1~deb11u1fixed
bookworm, bookworm (security)115.7.0esr-1~deb12u1fixed
trixie115.7.0esr-1fixed
sid115.8.0esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:115.7.0-1~deb10u1fixed
bullseye (security), bullseye1:115.7.0-1~deb11u1fixed
bookworm, bookworm (security)1:115.7.0-1~deb12u1fixed
sid, trixie1:115.7.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)102.0-1
firefox-esrsourcestretch91.11.0esr-1~deb9u1DLA-3064-1
firefox-esrsourcebuster91.11.0esr-1~deb10u1DSA-5172-1
firefox-esrsourcebullseye91.11.0esr-1~deb11u1DSA-5172-1
firefox-esrsource(unstable)91.11.0esr-1
thunderbirdsourcebuster1:91.11.0-1~deb10u1DSA-5175-1
thunderbirdsourcebullseye1:91.11.0-1~deb11u1DSA-5175-1
thunderbirdsource(unstable)1:91.11.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2022-24/#CVE-2022-34481
https://www.mozilla.org/en-US/security/advisories/mfsa2022-25/#CVE-2022-34481
https://www.mozilla.org/en-US/security/advisories/mfsa2022-26/#CVE-2022-34481

Search for package or bug name: Reporting problems