CVE-2022-34684

NameCVE-2022-34684
DescriptionNVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer (nvidia.ko), where an off-by-one error may lead to data tampering or information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1025279, 1025285, 1025286, 1025287

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-graphics-drivers (PTS)buster/non-free418.226.00-3vulnerable
bullseye/non-free470.161.03-1vulnerable
bookworm/non-free510.108.03-3fixed
sid/non-free515.86.01-1fixed
nvidia-graphics-drivers-tesla (PTS)bookworm/non-free510.108.03-3fixed
sid/non-free515.86.01-1fixed
nvidia-graphics-drivers-tesla-470 (PTS)bullseye/non-free470.161.03-1~deb11u1vulnerable
sid/non-free, bookworm/non-free470.161.03-1fixed
nvidia-graphics-drivers-tesla-510 (PTS)sid/non-free, bookworm/non-free510.108.03-1fixed
nvidia-open-gpu-kernel-modules (PTS)sid/contrib515.86.01-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-graphics-driverssource(unstable)510.108.03-11025279
nvidia-graphics-drivers-teslasource(unstable)510.108.03-11025287
nvidia-graphics-drivers-tesla-470source(unstable)470.161.03-11025285
nvidia-graphics-drivers-tesla-510source(unstable)510.108.03-11025286
nvidia-open-gpu-kernel-modulessource(unstable)515.86.01-1

Notes

[bullseye] - nvidia-graphics-drivers <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-470 <no-dsa> (Non-free not supported)

Search for package or bug name: Reporting problems