CVE-2022-34927

NameCVE-2022-34927
DescriptionMilkyTracker v1.03.00 was discovered to contain a stack overflow via the component LoaderXM::load. This vulnerability is triggered when the program is supplied a crafted XM module file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1016578

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
milkytracker (PTS)buster1.02.00+dfsg-1+deb10u1vulnerable
bullseye1.03.00+dfsg-1vulnerable
bookworm, sid1.03.00+dfsg-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
milkytrackersource(unstable)(unfixed)1016578

Notes

https://github.com/milkytracker/MilkyTracker/commit/3a5474f9102cbdc10fbd9e7b1b2c8d3f3f45d91b
https://github.com/milkytracker/MilkyTracker/issues/275

Search for package or bug name: Reporting problems