CVE-2022-3515

NameCVE-2022-3515
DescriptionA vulnerability was found in the Libksba library due to an integer overflow within the CRL parser. The vulnerability can be exploited remotely for code execution on the target system by passing specially crafted data to the application, for example, a malicious S/MIME attachment.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3153-1, DSA-5255-1
Debian Bugs1021928

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libksba (PTS)buster1.3.5-2vulnerable
buster (security)1.3.5-2+deb10u2fixed
bullseye1.5.0-3+deb11u1fixed
bullseye (security)1.5.0-3+deb11u2fixed
bookworm, sid1.6.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libksbasourcebuster1.3.5-2+deb10u1DLA-3153-1
libksbasourcebullseye1.5.0-3+deb11u1DSA-5255-1
libksbasource(unstable)1.6.2-11021928

Notes

https://gnupg.org/blog/20221017-pepe-left-the-ksba.html
https://dev.gnupg.org/T6230
https://dev.gnupg.org/rK4b7d9cd4a018898d7714ce06f3faf2626c14582b

Search for package or bug name: Reporting problems