CVE-2022-37601

NameCVE-2022-37601
DescriptionPrototype pollution vulnerability in function parseQuery in parseQuery.js in webpack loader-utils 2.0.0 via the name variable in parseQuery.js.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-loader-utils (PTS)buster1.1.0-2vulnerable
bullseye2.0.0-1vulnerable
bookworm, sid2.0.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-loader-utilssource(unstable)2.0.3-1

Notes

[bullseye] - node-loader-utils <no-dsa> (Minor issue; will be fixed via point release)
https://github.com/webpack/loader-utils/issues/212
https://github.com/webpack/loader-utils/commit/a93cf6f4702012030f6b5ee8340d5c95ec1c7d4c (v2.0.3)

Search for package or bug name: Reporting problems