CVE-2022-39831

NameCVE-2022-39831
DescriptionAn issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact. This issue is different from CVE-2018-20230.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1019597

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pspp (PTS)buster1.2.0-3vulnerable
bullseye1.4.1-1vulnerable
bookworm, sid1.6.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
psppsource(unstable)(unfixed)1019597

Notes

[bullseye] - pspp <no-dsa> (Minor issue)
[buster] - pspp <no-dsa> (Minor issue)
https://savannah.gnu.org/bugs/?62977

Search for package or bug name: Reporting problems