CVE-2022-40152

NameCVE-2022-40152
DescriptionThose using Woodstox to parse XML data may be vulnerable to Denial of Service attacks (DOS) if DTD support is enabled. If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow. This effect may support a denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1032089

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwoodstox-java (PTS)buster1:5.1.0-2vulnerable
bookworm, sid, bullseye1:6.2.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwoodstox-javasource(unstable)(unfixed)1032089

Notes

[bookworm] - libwoodstox-java <no-dsa> (Minor issue)
[bullseye] - libwoodstox-java <no-dsa> (Minor issue)
[buster] - libwoodstox-java <no-dsa> (Minor issue)
https://github.com/x-stream/xstream/issues/304
https://github.com/advisories/GHSA-3f7h-mf4q-vrm4

Search for package or bug name: Reporting problems