CVE-2022-41318

NameCVE-2022-41318
DescriptionA buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3151-1, DSA-5258-1
Debian Bugs1020586

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u7vulnerable
buster (security)4.6-1+deb10u10fixed
bullseye (security), bullseye4.13-10+deb11u2fixed
bookworm5.7-2fixed
sid, trixie6.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcebuster4.6-1+deb10u8DLA-3151-1
squidsourcebullseye4.13-10+deb11u2DSA-5258-1
squidsource(unstable)5.7-11020586
squid3source(unstable)(unfixed)

Notes

https://www.openwall.com/lists/oss-security/2022/09/23/2
Squid 4: http://www.squid-cache.org/Versions/v4/changesets/SQUID-2022_2.patch
Squid 5: http://www.squid-cache.org/Versions/v5/changesets/SQUID-2022_2.patch (5.7)

Search for package or bug name: Reporting problems