CVE-2022-41550

NameCVE-2022-41550
DescriptionGNU oSIP v5.3.0 was discovered to contain an integer overflow via the component osip_body_parse_header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1021662

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libosip2 (PTS)buster, bullseye4.1.0-2.1vulnerable
bookworm, sid5.3.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libosip2source(unstable)(unfixed)1021662

Notes

[bullseye] - libosip2 <no-dsa> (Minor issue)
[buster] - libosip2 <no-dsa> (Minor issue)
https://savannah.gnu.org/bugs/?63103
https://git.savannah.gnu.org/cgit/osip.git/commit/?id=f77f16c832c3c37589c2b749f01b644dc44a55b5

Search for package or bug name: Reporting problems