CVE-2022-41556

NameCVE-2022-41556
DescriptionA resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5243-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lighttpd (PTS)buster1.4.53-4+deb10u2fixed
buster (security)1.4.53-4+deb10u3fixed
bullseye1.4.59-1+deb11u1vulnerable
bullseye (security)1.4.59-1+deb11u2fixed
bookworm, sid1.4.67-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lighttpdsourcebuster(not affected)
lighttpdsourcebullseye1.4.59-1+deb11u2DSA-5243-1
lighttpdsource(unstable)1.4.67-1

Notes

[buster] - lighttpd <not-affected> (vulnerable code inserted in lighttpd-1.4.55-211-gbcddbe18)
https://github.com/lighttpd/lighttpd1.4/pull/115
Introduced by: https://github.com/lighttpd/lighttpd1.4/commit/bcddbe186f010e2964f7551141c0b8350b36817d (lighttpd-1.4.56-rc1)
Fixed by: https://github.com/lighttpd/lighttpd1.4/commit/b18de6f9264f914f7bf493abd3b6059343548e50 (lighttpd-1.4.67)

Search for package or bug name: Reporting problems