CVE-2022-41742

NameCVE-2022-41742
DescriptionNGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3203-1, DSA-5281-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)buster1.14.2-2+deb10u4vulnerable
buster (security)1.14.2-2+deb10u5fixed
bullseye1.18.0-6.1+deb11u2vulnerable
bullseye (security)1.18.0-6.1+deb11u3fixed
bookworm1.22.1-1fixed
sid1.22.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsourcebuster1.14.2-2+deb10u5DLA-3203-1
nginxsourcebullseye1.18.0-6.1+deb11u3DSA-5281-1
nginxsource(unstable)1.22.1-1

Notes

https://github.com/nginx/nginx/commit/6b022a5556af22b6e18532e547a6ae46b0d8c6ea (release-1.22.1)
Only affects the nginx-extras binary package

Search for package or bug name: Reporting problems