CVE-2022-41767

NameCVE-2022-41767
DescriptionAn issue was discovered in MediaWiki before 1.35.8, 1.36.x and 1.37.x before 1.37.5, and 1.38.x before 1.38.3. When changes made by an IP address are reassigned to a user (using reassignEdits.php), the changes will still be attributed to the IP address on Special:Contributions when doing a range lookup.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3148-1, DSA-5246-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2vulnerable
buster (security)1:1.31.16-1+deb10u7fixed
bullseye (security), bullseye1:1.35.13-1~deb11u1fixed
bookworm, bookworm (security)1:1.39.5-1~deb12u1fixed
sid, trixie1:1.39.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcebuster1:1.31.16-1+deb10u4DLA-3148-1
mediawikisourcebullseye1:1.35.8-1~deb11u1DSA-5246-1
mediawikisource(unstable)1:1.35.8-1

Notes

https://phabricator.wikimedia.org/T316304
https://gerrit.wikimedia.org/r/c/mediawiki/core/+/836891

Search for package or bug name: Reporting problems