CVE-2022-44638

NameCVE-2022-44638
DescriptionIn libpixman in Pixman before 0.42.2, there is an out-of-bounds write (aka heap-based buffer overflow) in rasterize_edges_8 due to an integer overflow in pixman_sample_floor_y.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3179-1, DSA-5276-1
Debian Bugs1023427

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pixman (PTS)buster0.36.0-1vulnerable
buster (security)0.36.0-1+deb10u1fixed
bullseye0.40.0-1vulnerable
bullseye (security)0.40.0-1.1~deb11u1fixed
bookworm, sid0.42.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pixmansourcebuster0.36.0-1+deb10u1DLA-3179-1
pixmansourcebullseye0.40.0-1.1~deb11u1DSA-5276-1
pixmansource(unstable)0.40.0-1.11023427

Notes

https://gitlab.freedesktop.org/pixman/pixman/-/commit/a1f88e842e0216a5b4df1ab023caebe33c101395 (pixman-0.42.2)
https://gitlab.freedesktop.org/pixman/pixman/-/issues/63

Search for package or bug name: Reporting problems