CVE-2022-47015

NameCVE-2022-47015
DescriptionMariaDB Server before 10.3.34 thru 10.9.3 is vulnerable to Denial of Service. It is possible for function spider_db_mbase::print_warnings to dereference a null pointer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3444-1
Debian Bugs1034889

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb (PTS)bookworm1:10.11.6-0+deb12u1fixed
trixie1:10.11.6-2fixed
sid1:10.11.7-3fixed
mariadb-10.3 (PTS)buster1:10.3.34-0+deb10u1vulnerable
buster (security)1:10.3.39-0+deb10u2fixed
mariadb-10.5 (PTS)bullseye1:10.5.23-0+deb11u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadbsourceexperimental1:10.11.3-1~exp1
mariadbsource(unstable)1:10.11.3-11034889
mariadb-10.3sourcebuster1:10.3.39-0+deb10u1DLA-3444-1
mariadb-10.3source(unstable)(unfixed)
mariadb-10.5sourcebullseye1:10.5.20-0+deb11u1
mariadb-10.5source(unstable)(unfixed)
mariadb-10.6source(unstable)(unfixed)

Notes

https://jira.mariadb.org/browse/MDEV-29644

Search for package or bug name: Reporting problems