CVE-2022-48503

NameCVE-2022-48503
DescriptionThe issue was addressed with improved bounds checks. This issue is fixed in tvOS 15.6, watchOS 8.7, iOS 15.6 and iPadOS 15.6, macOS Monterey 12.5, Safari 15.6. Processing web content may lead to arbitrary code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5240-1, DSA-5241-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.6-0+deb10u1fixed
bullseye2.42.2-1~deb11u1fixed
bullseye (security)2.42.5-1~deb11u1fixed
bookworm2.42.2-1~deb12u1fixed
bookworm (security)2.42.5-1~deb12u1fixed
trixie2.42.5-1fixed
sid2.44.1-1fixed
wpewebkit (PTS)bullseye, bullseye (security)2.38.6-1~deb11u1fixed
bookworm2.38.6-1fixed
trixie2.42.5-1fixed
sid2.44.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebullseye2.38.0-1~deb11u1DSA-5240-1
webkit2gtksource(unstable)2.38.0-1
wpewebkitsourcebullseye2.38.0-1~deb11u1DSA-5241-1
wpewebkitsource(unstable)2.38.0-1

Notes

https://webkitgtk.org/security/WSA-2023-0005.html

Search for package or bug name: Reporting problems