CVE-2022-48620

NameCVE-2022-48620
Descriptionuev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1060692

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libuev (PTS)bullseye2.3.1-1vulnerable
trixie, bookworm2.4.0-1.1vulnerable
sid2.4.0-1.2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libuevsource(unstable)(unfixed)1060692

Notes

[bookworm] - libuev <no-dsa> (Minor issue)
[bullseye] - libuev <no-dsa> (Minor issue)
https://github.com/troglobit/libuev/issues/27
https://github.com/troglobit/libuev/commit/2d9f1c9ce655cc38511aeeb6e95ac30914f7aec9 (v2.4.1)

Search for package or bug name: Reporting problems