CVE-2023-22332

NameCVE-2023-22332
DescriptionInformation disclosure vulnerability exists in Pgpool-II 4.4.0 to 4.4.1 (4.4 series), 4.3.0 to 4.3.4 (4.3 series), 4.2.0 to 4.2.11 (4.2 series), 4.1.0 to 4.1.14 (4.1 series), 4.0.0 to 4.0.21 (4.0 series), All versions of 3.7 series, All versions of 3.6 series, All versions of 3.5 series, All versions of 3.4 series, and All versions of 3.3 series. A specific database user's authentication information may be obtained by another database user. As a result, the information stored in the database may be altered and/or database may be suspended by a remote attacker who successfully logged in the product with the obtained credentials.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1030048

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pgpool2 (PTS)bullseye4.1.4-3vulnerable
bookworm4.3.5-1fixed
sid, trixie4.5.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pgpool2source(unstable)4.3.5-11030048

Notes

[bullseye] - pgpool2 <no-dsa> (Minor issue)
[buster] - pgpool2 <postponed> (Minor issue, restricted system account password hash leak to authentified users)
https://www.pgpool.net/mediawiki/index.php/Main_Page#News

Search for package or bug name: Reporting problems