CVE-2023-23589

NameCVE-2023-23589
DescriptionThe SafeSocks option in Tor before 0.4.7.13 has a logic error in which the unsafe SOCKS4 protocol can be used but not the safe SOCKS4a protocol, aka TROVE-2022-002.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3286-1, DSA-5320-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)buster0.3.5.16-1vulnerable
buster (security)0.3.5.16-1+deb10u1fixed
bullseye0.4.5.10-1~deb11u1vulnerable
bullseye (security)0.4.5.16-1fixed
bookworm, sid0.4.7.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsourcebuster0.3.5.16-1+deb10u1DLA-3286-1
torsourcebullseye0.4.5.16-1DSA-5320-1
torsource(unstable)0.4.7.13-1

Notes

https://gitlab.torproject.org/tpo/core/tor/-/raw/release-0.4.7/ReleaseNotes
https://gitlab.torproject.org/tpo/core/tor/-/issues/40730
https://gitlab.torproject.org/tpo/core/tor/-/commit/a282145b3634547ab84ccd959d0537c021ff7ffc

Search for package or bug name: Reporting problems