CVE-2023-24056

NameCVE-2023-24056
DescriptionIn pkgconf through 1.9.3, variable duplication can cause unbounded string expansion due to incorrect checks in libpkgconf/tuple.c:pkgconf_tuple_parse. For example, a .pc file containing a few hundred bytes can expand to one billion bytes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pkgconf (PTS)buster1.6.0-1vulnerable
bullseye1.7.4~git20210206+dcf529b-3vulnerable
bookworm, sid1.8.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pkgconfsource(unstable)1.8.1-1

Notes

[bullseye] - pkgconf <no-dsa> (Minor issue)
https://gitea.treehouse.systems/ariadne/pkgconf/commit/81cc9b3e6dafcdd02579bcccec6ac47d91e5d023 (pkgconf-1.9.4, pkgconf-1.8.1)
https://nullprogram.com/blog/2023/01/18/

Search for package or bug name: Reporting problems