CVE-2023-27830

NameCVE-2023-27830
DescriptionTightVNC before v2.8.75 allows attackers to escalate privileges on the host operating system via replacing legitimate files with crafted files when executing a file transfer. This is due to the fact that TightVNC runs in the backend as a high-privileges account.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tightvnc (PTS)buster1:1.3.9-9+deb10u1fixed
bullseye1:1.3.10-3fixed
trixie, sid, bookworm1:1.3.10-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tightvncsource(unstable)(not affected)

Notes

- tightvnc <not-affected> (Windows-specific)
https://medium.com/nestedif/vulnerability-disclosure-privilege-escalation-tightvnc-8165208cce

Search for package or bug name: Reporting problems