Information on source package tightvnc

Available versions

ReleaseVersion
stretch1:1.3.9-9+deb9u1
buster1:1.3.9-9+deb10u1
bullseye1:1.3.10-3
sid1:1.3.10-3

Resolved issues

BugDescription
CVE-2019-15681LibVNC commit before d01e1bb4246323ba6fcee3b82ef1faa9b1dac82a contains ...
CVE-2019-15680TightVNC code version 1.3.10 contains null pointer dereference in Hand ...
CVE-2019-15679TightVNC code version 1.3.10 contains heap buffer overflow in Initiali ...
CVE-2019-15678TightVNC code version 1.3.10 contains heap buffer overflow in rfbServe ...
CVE-2019-8287TightVNC code version 1.3.10 contains global buffer overflow in Handle ...
CVE-2018-20022LibVNC before 2f5b2ad1c6c99b1ac6482c95844a84d66bb52838 contains multip ...
CVE-2018-20021LibVNC before commit c3115350eb8bb635d0fdb4dbbb0d0541f38ed19c contains ...
CVE-2018-7225An issue was discovered in LibVNCServer through 0.9.11. rfbProcessClie ...
CVE-2014-6053The rfbProcessClientNormalMessage function in libvncserver/rfbserver.c ...
CVE-2009-0388Multiple integer signedness errors in (1) UltraVNC 1.0.2 and 1.0.5 and ...
CVE-2002-1336TightVNC before 1.2.6 generates the same challenge string for multiple ...

Security announcements

DSA / DLADescription
DLA-2045-1tightvnc - security update

Search for package or bug name: Reporting problems