DescriptionIrssi 1.3.x and 1.4.x before 1.4.4 has a use-after-free because of use of a stale special collector reference. This occurs when printing of a non-formatted line is concurrent with printing of a formatted line.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1033785

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)buster1.2.0-2+deb10u1fixed
bookworm, sid1.4.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisourcebuster(not affected)
irssisourcebullseye(not affected)


[bullseye] - irssi <not-affected> (Vulnerable code introduced later)
[buster] - irssi <not-affected> (Vulnerable code introduced later)

Search for package or bug name: Reporting problems