CVE-2023-32435

NameCVE-2023-32435
DescriptionA memory corruption issue was addressed with improved state management. This issue is fixed in macOS Ventura 13.3, Safari 16.4, iOS 16.4 and iPadOS 16.4, iOS 15.7.7 and iPadOS 15.7.7. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS released before iOS 15.7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5396-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.6-0+deb10u1vulnerable
bullseye2.42.2-1~deb11u1fixed
bullseye (security)2.44.2-1~deb11u1fixed
bookworm2.42.2-1~deb12u1fixed
bookworm (security)2.44.2-1~deb12u1fixed
sid, trixie2.44.2-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.38.6-1~deb11u1vulnerable
bookworm2.38.6-1vulnerable
sid, trixie2.44.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster(unfixed)end-of-life
webkit2gtksourcebullseye2.40.1-1~deb11u1DSA-5396-1
webkit2gtksource(unstable)2.40.0-1
wpewebkitsource(unstable)2.40.2-2

Notes

[buster] - webkit2gtk <end-of-life> (webkit2gtk EOL in buster)
[bookworm] - wpewebkit <ignored> (wpewebkit not covered by security support in Bookworm)
[bullseye] - wpewebkit <ignored> (wpewebkit >= 2.40 can no longer be sensibly backported)
https://webkitgtk.org/security/WSA-2023-0005.html

Search for package or bug name: Reporting problems