CVE-2023-32762

NameCVE-2023-32762
DescriptionAn issue was discovered in Qt before 5.15.14, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.1. Qt Network incorrectly parses the strict-transport-security (HSTS) header, allowing unencrypted connections to be established, even when explicitly prohibited by the server. This happens if the case used for this header does not exactly match.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3805-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt6-base (PTS)bookworm6.4.2+dfsg-10fixed
sid, trixie6.4.2+dfsg-21.1fixed
qtbase-opensource-src (PTS)buster5.11.3+dfsg1-1+deb10u5vulnerable
buster (security)5.11.3+dfsg1-1+deb10u6fixed
bullseye5.15.2+dfsg-9vulnerable
bookworm5.15.8+dfsg-11fixed
trixie5.15.10+dfsg-7.2fixed
sid5.15.13+dfsg-2fixed
qtbase-opensource-src-gles (PTS)bullseye5.15.2+dfsg-4fixed
bookworm5.15.8+dfsg-3fixed
trixie5.15.10+dfsg-6fixed
sid5.15.13+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt6-basesource(unstable)6.4.2+dfsg-9
qtbase-opensource-srcsourcebuster5.11.3+dfsg1-1+deb10u6DLA-3805-1
qtbase-opensource-srcsource(unstable)5.15.8+dfsg-10
qtbase-opensource-src-glessource(unstable)(not affected)

Notes

[bullseye] - qtbase-opensource-src <no-dsa> (Minor issue)
- qtbase-opensource-src-gles <not-affected> (Not built in GLES variant)
https://github.com/qt/qtbase/commit/1b736a815be0222f4b24289cf17575fc15707305

Search for package or bug name: Reporting problems