CVE-2023-37770

NameCVE-2023-37770
Descriptionfaust commit ee39a19 was discovered to contain a stack overflow via the component boxppShared::print() at /boxes/ppbox.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faust (PTS)buster2.14.4~repack2-1vulnerable
bullseye2.30.5~ds0-2vulnerable
bookworm2.54.9+ds0-1vulnerable
trixie2.70.3+ds-1vulnerable
sid2.70.3+ds-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faustsource(unstable)(unfixed)unimportant

Notes

https://github.com/grame-cncm/faust/issues/922
Negligible security impact

Search for package or bug name: Reporting problems