CVE-2023-3824

NameCVE-2023-3824
DescriptionIn PHP version 8.0.* before 8.0.30,  8.1.* before 8.1.22, and 8.2.* before 8.2.8, when loading phar file, while reading PHAR directory entries, insufficient length checking may lead to a stack buffer overflow, leading potentially to memory corruption or RCE.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3555-1
Debian Bugs1043477

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.3 (PTS)buster7.3.31-1~deb10u1vulnerable
buster (security)7.3.31-1~deb10u5fixed
php7.4 (PTS)bullseye (security), bullseye7.4.33-1+deb11u4vulnerable
php8.2 (PTS)bookworm, bookworm (security)8.2.7-1~deb12u1vulnerable
trixie8.2.12-1fixed
sid8.2.16-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.3sourcebuster7.3.31-1~deb10u5DLA-3555-1
php7.3source(unstable)(unfixed)
php7.4source(unstable)(unfixed)
php8.2source(unstable)8.2.10-11043477

Notes

[bookworm] - php8.2 <postponed> (Fix along in future update)
[bullseye] - php7.4 <postponed> (Fix along in future update)
https://github.com/php/php-src/security/advisories/GHSA-jqcx-ccgc-xwhv
https://github.com/php/php-src/commit/80316123f3e9dcce8ac419bd9dd43546e2ccb5ef (php-8.0.30)
Fixed in: 8.0.30, 8.1.22, 8.2.8

Search for package or bug name: Reporting problems