CVE-2023-39534

NameCVE-2023-39534
Descriptioneprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.10.0, 2.9.2, and 2.6.5, a malformed GAP submessage can trigger assertion failure, crashing FastDDS. Version 2.10.0, 2.9.2, and 2.6.5 contain a patch for this issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5481-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fastdds (PTS)bullseye (security), bullseye2.1.0+ds-9+deb11u1fixed
bookworm, bookworm (security)2.9.1+ds-1+deb12u2fixed
sid2.14.0+ds-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fastddssourcebullseye2.1.0+ds-9+deb11u1DSA-5481-1
fastddssourcebookworm2.9.1+ds-1+deb12u1DSA-5481-1
fastddssource(unstable)2.10.1+ds-2

Notes

https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-fcr6-x23w-94wp
https://github.com/eProsima/Fast-DDS/commit/2674fdd93793fd314fcb81b795f9f62b8fcb1ea0
https://github.com/eProsima/Fast-DDS/pull/3343

Search for package or bug name: Reporting problems